Author Topic: Water Pump  (Read 644 times)

Offline jasonrebecca

  • Senior Member
  • ****
  • Posts: 454
Water Pump
« on: July 22, 2017, 10:22:54 pm »
So, first time needing the water pump in a while. Turned it on and water came out the City water connection. But when hooked up to city water everything is fine. We have used the pump several times in the past without issue. Checked all connections and everything is where it should be. Thinking about replacing it, any recommendations?
2015 F150 EcoBoost
2008 Outback 21rs
DH (Jason) DW(Rebecca) DS(Oliver '11)  DD (Emily '14)DG (Penny '17)

Offline Nathan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2223
  • Westward Ho!
Re: Water Pump
« Reply #1 on: July 23, 2017, 11:38:55 am »
Backflow valve at the city water connection has failed. Typically you have to replace the city connection. Alternatively connect a shutoff valve to the city connection and you can use the pump until you get it fixed


Sent from my iPhone using Tapatalk
Nathan, DW, DS '03, DD '06 

Offline Willingtonpaul

  • Hero Member
  • *****
  • Posts: 4357
  • Live for today; Plan for tomorrow....
Re: Water Pump
« Reply #2 on: July 28, 2017, 11:45:55 pm »
 :agree:
2018 Newmar Dutch Star 4326
2014 Jeep Wrangler Unlimited Rubicon
2015 Ford F150 Fing Ranch
Paul('69) Adele('68) Mila('03) Ethan('05)
Lara the Golden ('13)
Brewster the Golden ('17)

Just doing my part to control the flying insect population with camping every trip....

Offline jasonrebecca

  • Senior Member
  • ****
  • Posts: 454
Re: Water Pump
« Reply #3 on: March 09, 2018, 08:40:20 pm »
Wow, I haven't been on here in a while. I did replace the water connections on the outside of the trailer and that fixed the issue.


Sent from my iPhone using Tapatalk
2015 F150 EcoBoost
2008 Outback 21rs
DH (Jason) DW(Rebecca) DS(Oliver '11)  DD (Emily '14)DG (Penny '17)

 

Powered by EzPortal